快三彩票开户

您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

分享的不錯的MACD背離公式(副圖指標公式 公式、源碼 演示圖)[通達信公式]

相關標簽: 通達信15分鐘選股公式 、 macd背離指標源碼 、 macd紅二波成功率高嗎 、 30分鐘macd底背離戰法 、 macd頂底背離主圖指標 、 頂底背離指標公式 、 macd金叉選股公式 、

?

一直在用,感覺不錯,各位感興趣的拿去研究研究,必有所得

?

?

原理解析:


?

?來源:程序化99( cotps.com )

源碼:

?

?

DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORRED,LINETHICK2;
DEA:EMA(DIF,9),COLORWHITE,LINETHICK2;
持倉段:=0,COLOR00CFFF;
空倉段:=0,COLORFFCCFF;
STICKLINE(DIF>DEA,-0.5,-0.6,10,1),COLOR00CFFF;
STICKLINE(DIF<DEA,-0.5,-0.6,10,1),COLORFFCCFF;
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(((MACD<REF(MACD,1))AND(MACD>0)),0,MACD,1,0),COLORLIBLUE,LINETHICK2;
STICKLINE(((MACD>REF(MACD,1))AND(MACD<0)),0,MACD,1,0),COLORFF00FF,LINETHICK2;
建倉:IF(DIF<0,DIF,0),COLORYELLOW,LINETHICK2;
加倉:IF(DIF<0,0,DIF),COLORRED,LINETHICK2;
白線破倉:IF(DIF<DEA,DIF,DEA),COLORWHITE,LINETHICK2;
趨勢強弱:IF(DIF>DEA,DEA,DEA),COLORFF937F,LINETHICK2;

AA:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA)ANDDEA<0ANDCOUNT(AA=2,21)=1;
DRAWTEXT(二次金叉,0.2,'二次金叉'),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背離:=REF(CLOSE,A1+1)>CLOSEANDDIF>REF(DIF,A1+1)ANDCROSS(DIF,DEA);
STICKLINE(底背離,0,0.03,6,0),COLOR00FF00;
底背:DRAWLINE(A1=0,DEA,底背離,DEA,0),COLORRED,LINETHICK4;
DRAWTEXT(底背離,0.12,'底背離'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
頂背離:=REF(CLOSE,A2+1)<CLOSEANDREF(DIF,A2+1)>DIFANDCROSS(DEA,DIF);
頂背:DRAWLINE(A2=0,DEA,頂背離,DEA,0),COLORGREEN,LINETHICK4; 

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

快三彩票开户有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容